Openshot refuses to use any of the frei0r mixer2 plugins

Audio & Visual effects.

Moderators: Andy, Cenwen, beats

Openshot refuses to use any of the frei0r mixer2 plugins

Postby fjdebruijn » Tue Nov 03, 2015 12:38 am

Hello, I am trying to write a custom effect for openshot using the frei0r framework, however when i try to use any of the mixer class plugins openshot refuses to load them.

for example I try to use frei0r.blend

the file is /usr/lib/python2.7/site-packages/openshot/effects/aaa.xml

Code: Select all
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE openshot-effect>
<effect>
   <title translatable="True">aaa</title>
   <description translatable="True">blend</description>
   <icon>hue.png</icon>
   <category>Video</category>
   <service>frei0r.blend</service>
</effect>


I run openshot from a terminal, select the effects tab and it throws this debug error through the console.

Code: Select all
Warning: effect not found in your version of Frei0r: frei0r.blend


I have checked to see if MLT can see the plugin and it can.

Code: Select all
$ melt -query plugins |grep frei0r.b
  - frei0r.balanc0r
  - frei0r.baltan
  - frei0r.bluescreen0r
  - frei0r.brightness
  - frei0r.bw0r
  - frei0r.blend
  - frei0r.burn


The nature of the effect needs to mix 2 video channels together to form 1 channel. just trying to get started using the existing mixer plugins is not giving me any luck.
Am i doing anything wrong or is this a limitation of openshot and if so should i be looking at writing the effect for MLT instead ?
fjdebruijn
New member
 
Posts: 1
Joined: Tue Nov 03, 2015 12:22 am

Re: Openshot refuses to use any of the frei0r mixer2 plugins

Postby XXLRay » Fri Nov 06, 2015 12:12 pm

That't strange. Looks absolutely fine to me.

Edit: The problem may be that blend is a transition and not exactly an effect.
XXLRay
OpenShot Veteran
 
Posts: 1070
Joined: Fri Jul 06, 2012 4:10 pm


Return to Effects

Who is online

Users browsing this forum: Bing [Bot]